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1. Introductory material 

 

A short introduction to oil spill and Synthetic Aperture Radar (SAR) 

 
Major oil spills from sinking supertankers, or other marine accidents like the Deepwater 
Horizon (DWH) oil rig explosion and collapse 
(https://www.britannica.com/event/Deepwater-Horizon-oil-spill), are thankfully very 
rare these days. However, smaller oil spills from shipping are unfortunately still 
common. Most ships have some type of fuel on board and if they are involved in an 
accident, there is a risk of that fuel leaking into the sea. More information about the 
major oil spills disasters at sea can be found at: https://markleen.com/oil-spill-
response/major-oil-spill-disasters-at-sea/ 
 
More worryingly, some ships still deliberately release oil into the sea. A common 
practice is pumping out oil-laden water from below deck while at sea. Although small, 
these events can still be extremely harmful particularly when they occur in sensitive 
marine environments. There are real concerns that many remain undetected. Inevitably 
some oil from spills reaches land. It is then up to local authorities and national 
governments to clean it up. Numerous techniques exist for containing oil at sea although 
none are completely effective. Cleaning it up, once it hits land, usually involves a 
combination of manually removing oil, flushing with water or even just wiping it off 
with absorbent rags.   
 
In some areas even reaching the oil can be as hard as cleaning it up. Mud flats, swamps, 
marsh-lands and deltas can be particularly difficult. The Prestige oil tanker disaster in 
2002 in the Spanish Galician coast was an example of that 
(https://www.bbc.com/news/world-europe-24930976). 
 

 
Stock Photo - Soldiers dressed with protective clothing cleaning up the oil spill 

(´chapapote´) from Prestige tanker. Dec. 2002. Costa da Morte. La Coruña 

province. Galicia. Spain 

 



The all-weather and day-and-night sensing capabilities, spatial coverage, revisit time, 
and scattering of the SAR signal are some of the features that allow the use of 
Copernicus Sentinel-1A/B as source of information for an oil spill surveillance 
program. The backscatter of the SAR signal over the ocean is mainly a result of sea 
roughness (i.e. short gravity-capillary waves). Oil films decrease the sea surface 
roughness and hence the backscatter by reducing the capillary wave and dumping of 
longer waves energy through the called Marangoni wave damping. These causes spills 
to appear darker in SAR images than spill-free areas. However, the contrast between 
polluted and non-polluted areas depends on different parameters such as wave height, 
wind speed, type of oil and sensor characteristics (wavelength, polarization, incident 
angle). 
 
SAR imagery over oceans usually contains oceanic and atmospheric phenomena 
referred to as look-alikes that can cause false alarm detections. They dampen the short 
waves and create dark patches on the surface, originating problems to distinguish them 
from oil spills. Look-alikes include natural films/slicks, grease ice, areas with specific 
wind speed, rain cells, internal waves, etc.   
 

 
(a) Verified oil spill on a SAR image. (b) Verified look-alike on a SAR image 

(Stathakis et al., 2006) 

  



Some information about the oil spill that you are going to analyse 

 
August 22 (Tuesday), 2017. 
 
DUBAI (Reuters) - Kuwait’s state oil company said on Tuesday that an oil spill off the 
country’s coast had been contained and that it was in contact with oil companies 
operating in the Gulf region to try to locate the source of the leak, state news agency 
KUNA said. 
 
Kuwait Petroleum Corporation said large amounts of the leaked oil had been removed 
and the rest contained during around-the-clock emergency operations that include air 
and sea monitoring. 
 
At least two spillages have hit different areas off the coast of the Gulf Arab state since 
last week. 
 
Kuwait reported a spill on Friday in the Ras al-Zour area near the southern border with 
Saudi Arabia and on Tuesday at Abu Fatira, about 15 miles (25 km) south of the capital 
Kuwait City. Authorities have not said what caused the spills. 
 
The size of the first spill was not given last week. Kuwait said on Tuesday the second 
spill spanned one nautical mile. 
 
Kuwait’s oil minister said on Monday that neighbouring Saudi Arabia and Iran had said 
they had not detected any oil spillage in their waters. 
 
The minister also said on Monday that electricity and water production had continued at 
full capacity at the Al-Zour North and Al-Zour South plants. 
 
Ras al-Zour is where Kuwait National Petroleum Co is building the Middle East’s 
largest oil refinery, with a processing capacity of 615,000 barrels per day and $11.5 
billion worth of contracts. 

 
13-08-2017: Oils spill in the coasts of Kuwait (The Associated Press). 



Some information about the image that you are going to use: YOU DON´T HAVE 

TO DO ANYTHING AT THIS STATE. 

 

Using the Copernicus Open Access Hub portal, we selected the product and date of 
interest. 
 

 
Selected area (left) and image preview (right). 

 
The image is offline, so we couldn’t download the file. We then initiated the 
downloading process by asking for the image. First, we added the product to the cart 
and then the following window popped-up. 
 

 
Offline product information. 

 
We had now the product in the cart but still not available for downloading as it is 
offline. 
 

 
Cart information about the image (Offline).  



It is possible to see if the product is still “Offline”, so if you try to download it you will 
see the following window: 
 

 
Product still being unavailable. 

 

After a couple of hours (or half an hour in other cases) you will see that the word 
“Offline” disappears, so the product is available in your cart: 
 

 
The selected image is now available in the cart. 

 
Now, it is possible to download the product. 
 

2. Previous Activity  

NOT TO BE DONE BY YOU!  

 
Open the SAR image in SNAP. IMPORTANT: You need to open the ZIP file with 
SNAP, so it is not necessary to unzip it before downloading the image. This is a unique 
characteristic of Sentinel-1 files when you download Sentinel-1 data from Copernicus 
Open Access Hub.  
 
The name of the file gives you some information of interest: 
 
S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_017855_01DEF7_F4
8C.zip 
 
The image was obtained in Interferometric Wide (IW) swath mode, which is the main 
acquisition mode over land and satisfies the majority of service requirements. The 
product is Ground Range Detected (GRD). This consists of focused SAR data that have 
been detected, multi-looked and projected to ground range using an Earth ellipsoid 
model. In that case, phase information is lost. The image was obtained by the Sentinel-
1A (S1A) satellite on 10th August 2017 (20170810). The sensing period was from 



02:47:14 hh:mm:ss (UTC time T024714) to 02:47:38 hh:mm:ss (T024738). The 
absolute orbit is: 017855. 
 
Once you open the product with SNAP, four bands are available so you need to select 
one of the bands in order to see it in the main screen. 
 

 
Image selected. 

 

Spatial Subset from View: this is a compulsory step as the size of the S1 image is huge 
(780MB). So, a smaller area has been created for you. The area selection can be made 
using the Pixel Coordinates or Geo Coordinates options. The blue square shown in 
the image preview is the selected area. 
 

 
Pixel coordinates of the selected sub-image. 

 
The subset product is now: 
 



 
Selected area. 

 
Once the subset is created, it needs to be saved. Save Product as…  
 

 
Saving the product (step 1) 

 

 
Saving the product (step 2) 

 

This step creates a BEAM-DIMAP file and a folder with the files corresponding with 
the area selected. These are the two products that you need to do the practical lesson. 
  



3. Now, it is your turn!  

Activity: Opening the image 

 
The products that you need in this practical lesson are already provided. Download the 
compressed file Practical_Lesson_1.rar into your computer. Uncompress the file in your 
working directory. You should have two files: 

• oil_spill_detection.dim. 

• subset_0_of_S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_
017855_01DEF7_F48C.dim.  

and two folders:  

• oil_spill_detection.data. 

• subset_0_of_S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_
017855_01DEF7_F48C.data. 

 
Open SNAP. Open the following file (File → Open product): 
subset_0_of_S1A_IW_GRDH_1SDV_20170810T024714_20170810T024738_017855
_01DEF7_F48C.dim. Once opened, double-click in the name of the file, so 4 directories 
should appear. Clicking in “Metadata” and then in “Abstracted_Metadata” you have in 
the main window plenty of information about the image.  
 

 
Product Explorer window 

 
Another important point is the spatial resolution of the image. That information can be 
obtained from “Abstracted_Metadata” as “Range sample spacing” and “Azimuth 
sample spacing”. These two parameters give you the pixel size in the range and azimuth 
direction. The spatial resolution is twice the pixel size. 
 



 
Basic geometry of a SAR side-looking system. 

 
Quiz question 1: 
Can you indicate the spatial resolution of the image in the range and azimuth direction? 

1. 40.0 x 40.0 m. 
2. 20.0 x 20.0 m. 
3. 10.0 x 10.0 m. 
4. 60.0 x 60.0 m. 

 
Close [1] Abstracted_Metadata from the main window. Click in the “+” button on the 
left of “Bands”.  
 

 
Product Explorer window. 

 
You have two bands (polarization modes of the instrument): VH (Vertical-Horizontal) 
and VV (Vertical-Vertical). You can see two images for each polarization: Amplitude 
and Intensity. Double-clicking in “Amplitude_VH”, you can see now the image 
corresponding to the selected area and selected band. If A is the amplitude of the signal, 
the Intensity I is: A2. 



 

 
Polarization modes. 

 

Activity: Orbit file 

 
The orbit state vectors provided in the metadata of a SAR product are generally not 
accurate and can be refined with the precise orbit files which are available days-to-
weeks after the generation of the product. The orbit file provides accurate satellite 
position and velocity information. Based on this information, the orbit state vectors in 
the abstract metadata of the product are updated. Orbit files are automatically 
downloaded from the ESA GNSS Hub, so you need an internet connection to do the 

next step! 
 
Click in Radar → Apply Orbit file. The only thing that you should change in the 
Orbit file window is the Directory of the Target Product (put the same directory where 
you placed the .dim files and the directories with the SAR image). Then click in 
Processing Parameters if you want to change something else, but that is not the case, 
so click in Run. When finished, click in Close.  
 

 
Orbit file window. 

 



When finished, a new product should appear in the product explorer window. If you 
click in the new images from the orbit corrected product, you can see different features 
in the image, especially over the ocean: 
 

 
Amplitude and Intensity of the two polarization images (VH and VV). 

 
Depending on your application, you will be interested in working with one type of 
image (polarization) or another.  
 
Quiz question 2: 
Which polarization do you think should be more appropriate for oil spill detection?  

1. Amplitude VV. 
2. Intensity VV. 
3. Amplitude VH. 
4. Intensity VH. 

 
Activity: Band Maths 

 
Now, you will learn how to use Band Maths. This is used to make operations between 
bands (images) in order to create new bands (images). You can apply simple 
mathematical expressions, constants, operators and functions.  
 
Using the Band Maths option from the Raster Menu you will calculate the ratio 
between the amplitude images: 
 

Amplitude_VV / Amplitude_VH. 
 
Click in Raster Menu and then in Band Maths. The following window should appear 
(you need to work with the orbit corrected file): 



 

 
Band maths main menu. 

 
Click in Edit Expression and type the ratio expression: 

 

 
Band math window. 

 
If you see the green Ok, no errors, you can finish clicking in Ok in Band Maths 

Expressions Editor and the again Ok in Band Maths. You can see that a new band has 
been created. 
 
A typical function with SNAP is the Red-Green-Blue composition in optical imageries. 
You will now learn how to do this with SAR images in order to use a colour-scale 
image for a better visual oil spill detection. Right click in the orbit product and then 
select Open RGB Image Window using the VV channel for red (amplitude), VH 
channel (amplitude) for green and the ratio |VV| / |VH| for blue. 
 



 
 

 
 
Once finished, click in Ok. The new band created shows in green the area affected by 
the oil spill. Right-click in the new images created (new_band_1 and Dual Pol Ratio 
Intensity VV+VH RGB) and delete them. If you go to Bands you can see that the new 
bands created are still there. Right click in the new_band_1 and click in Delete. Do the 
same with the other band. 
 
Activity: Speckle filter 

 
Speckle is caused by random constructive and destructive interference resulting in salt 
and pepper noise throughout the image. Speckle filters can be applied to the data to 
reduce the amount of speckle at the cost of blurred features or reduced resolution. The 
principle of speckle filtering is to reduce the variance of the complex speckled 
scattering and improve the estimate of the unspeckled scattering coefficient. 
 
Select the orbit corrected product. 
 



 
 
Click in Radar → Speckle Filtering → Single Product Speckle Filter. In the I/O 
Parameters, all the settings remain as default. In the Processing Parameters tab, select 
the bands: Amplitude_VH, Intensity_VH, Amplitude_VV, Intensity_VV. Leave the 
other settings as default. You will apply the Lee Sigma filter (do not change any of the 
options). 
 

 
Processing parameters window. 

 
Lee-sigma smooths the image noise by averaging only those neighbourhood pixels 
(window size: 7x7) which have the intensities within a fixed sigma probability of the 
Gaussian distribution range of the centre pixel (in our case 0.9).  
 
Click Run and when finished Close. Display the result afterwards. Click + to expand 
the content of the filtered product, then expand the Bands folder and double click in the 
Amplitude_VV band to visualize it. Open the Amplitude_VV of the unfiltered band 
(orbit corrected). 
 
Note: If you see the following error message, then rise your hand and we will try to help 

you: 

 



 
 
Activity: Oil spill profile plot 

 
To visualize how an oil spill affects the reflectance of the SAR signal we can display a 
profile of the amplitude value in the VV polarization mode (use the image Amplitude 

of the filtered image). Click in the line drawing tool icon  and draw a line through 
the oil spill that starts and ends in a non-oil spill area. Then, go to Analysis → Profile 

Plot.  
 

 
Example of a selected profile 

 

A profile plot with the magnitude of the digital numbers corresponding to the amplitude 
of VV polarization should appear. 
 
Quiz question 3: 
Which part of the transect (in terms of magnitude of the digital numbers) corresponds to 
the oils spill?  

1. Oil spill corresponds to pixels with the bigger amplitude values. 
2. Oil spill corresponds to pixels with the smaller amplitude values. 
3. All the pixels represented could correspond to oil spills. 
4. None of the previous answers are correct. 

 
Close the profile plot and remove the line by clicking in “esc” in the clipboard. The box 
with the yellow line should disappear.  
 
 



Activity: Oil Spill Mapping 

 
To identify oil spills in the ocean, we will use the dedicated tool that SNAP offers for 
this purpose. However, it has to be highlighted that only ‘possible oil spills’ are detected 
since some specific oceanic conditions can generate similar visual patterns to the ones 
of an oil spill (see the figure in the introduction). 
 
The oil spill detection tool includes two pre-processing steps:  
 

• mask out the inland areas; and  

• radiometric calibration so that pixel values truly represent the radar backscatter 
of the reflecting surface.  

 
After those pre-processing steps, dark spots are detected using an adaptive threshold 
algorithm where the local mean backscatter level is estimated using pixels in a large 
window. Then, a threshold is set to ‘k’ decibel below the local mean calculated before. 
Pixels within the window with values lower than the threshold are detected as dark spot. 
Finally, the detected pixels are clustered into a single cluster and those with sizes 
smaller than a predefined size selected by the user are eliminated. 
 
Click in Radar → SAR Applications → Ocean Applications → Oil Spill Detection. 
Follow the instructions to complete the parameters of each tab. 

• Read → select the speckle filtered product. 

• Land-Sea-Mask and Calibration → all the parameters remain as default. 

• Calibration → all the parameters remain as default. 

• Oil-Spill-Detection → Select only the Sigma0_VV as source band. Set the 
Background Window Size to 1400 and the Threshold Shift (dB) to 3.5 

• Oil-spill-clustering → the parameter remains as default  

• Write → all the parameters remain as default. 

IMPORTANT: DO NOT CLICK IN RUN!!!!!. This is because the processing will 
take a lot of time. We already made the processing and saved the product (it took about 
two hours!).  
 
Before opening the products, you can check how the masking of an image is made. 
Click in Raster → Masks → Land/Sea Mask. Select a Source (the filtered image) and 
a Target image (the default name is ok). On the Processing parameters tab you can 
select the Bands in which the mask will be applied. You can select only the 
Amplitude_VV. You can also select to mask out the land on the sea. You will use a 
SRTM (Shuttle Radar Topography Mission) product to apply the mask. Once finished, 
click in Run and then Close. 
 



 
Land/Sea Mask window. 

 
The land/mask operation is quite important in the oil spill detection as it allows to 
speed-up the procedure. The pixels considered as ‘land’ are not processed in the oil spill 
detection. If you make a zoom-in in the image close to the shore you will see that the 
land-mask is not optimal. This could be improved by using a high resolution land mask. 
Close the mask product created in the Product Explorer window. 
 
Open the product oil_spill_detection.dim. The output product is created as a binary 
mask that can be found on the ’Bands’ or ‘Masks’ folders of the product. Expand the 
bands folder and open the Sigma0_VV band. This is the land/mask band. 
 
Double-click in the band: Sigma0_VV_oil_spill_bit_msk. This band contains the mask 
corresponding to the oil spill detected by the algorithm. It is a black and white image. In 
this case the only pixel value is 1.0, corresponding to the white colour. 
 
To improve the visualization and contrast of the band Sigma0_VV, we can transform 
the pixel values using the decibels scale. For that, right click in the band Sigma0_VV 
and select Linear to/from dB and click in Yes.  
 

 
 
The image will be created and store as a virtual band. To save it, right click in the band 
Sigma0_VV_db and select Convert band. Then, double click in it to visualize it. 
 
Note: I was not able to complete this task in my computer at office, but I succeeded at 

home in my laptop. If the new band does not appear (Sigma0_VV_db), you can click in 

Colour Manipulation, then tick Basic and then in Colour ramp: select the colour 

palette: derived from Deimos_color_palette. This allows a higher contrast in the image. 

 



In order to have a better visualization of the oil spill mask, display it on top of the SAR 
image. For that, select Sigma0_VV_db and open the Layer Manager (Layer → Layer 

Manager), expand the ‘Mask’ folder and check the 
Sigma0_VV_oil_spill_bit_msk_detection band. If you make a zoom-in in the oil spill 
area you can see how well the algorithm worked. You can see that in some cases the 
algorithm was not able to isolate the oil spill. Even though, if you move to the coastal 
area in which red pixels are clearly seen, then you will realise that these are false alarms 
or false detections (look-alikes). This is due to the fact that the parameters introduced in 
the algorithm are not 100% effective in some cases. 
 

 
Image (Sigma0_VV_db) with the land and oil spill pixels masked. 

 
Activity: Ellipsoid correction 

 
After the oil spill detection is completed, we can reproject our image into a specific 
coordinate reference system. If you have a look at the following figure, then you will 
realise that the SAR image is not geometrically corrected. 
 

 
SAR image (not geometrically corrected) and same area from Google Earth TM.  

 
To perform this geometrical correction, we will use the Ellipsoid Correction. Click in 
Radar → Geometric → Ellipsoid Correction → Geolocation Grid. On the I/O 
Parameter tab, select the oil_spill_detection product and make sure to select the correct 
output path. Then, click in the Processing Parameters tab, then click in Map 

Projection and then select the UTM / WGS 84 (Automatic) projection and click Ok 

and then Run. When finished, Close. 
 



 
Map projection window. 

 
Apply the oil spill mask as previously: open the Layer Manager (Layer → Layer 

Manager), expand the ‘Mask’ folder and check the 
Sigma0_VV_oil_spill_bit_msk_detection band. If everything is ok, you should see the 
following product: 
 

 
Geometrically corrected image (Sigma0_VV) with the land and oil spill pixels 

masked. 
 
Quiz question 4: 
The inclination of the image respect to the horizontal plane depends on the:  

1. Speed of the satellite. 
2. Height of the satellite respect to the Earth surface. 
3. Position of the satellite respect to the Sun. 
4. Orbit of the satellite. 

 
Activity: Exporting the mask (this is optional) 

 
The mask with the oil spill can be exported to different formats for other applications, 
such as QGIS visualization and analysis. To export the mask, we will first change the 
colour. Open Sigma0_VV_oil_spill_bit_msk of the reprojected product. Click in 



Colour Manipulation tab, select the Table editor and set all the colours to red. Once 
the colour has changed, you can right click over the image in the main window, and 
select Export View as Image. Select a path to save the product, choose the option Full 

Scene in the image region section and write the name of the product. In Files of type 
you should select GeoTIFF – TIFF with geo-location. Then, click Save. Now, you 
have a GeoTIFF file with the mask corresponding to the oil spill.  
 
In the next figure, you can see the band Sigma0_VV with the oil spill and land masks 
applied (saved as GeoTIFF) opened with Matlab. In this case, the ellipsoid correction 
was made with the projection: Geographic Lat/Lon (WGS 84). 

 
So, this is the end, my only friend, the end… 
 


